Problems logging in as an admin via DCC chat

Back to PHP-IRC Bugs

Page: 1  
From User Message Body
Entropy
Post #464
user avatar
Member
Date: 10:07 pm, Feb 18 2007
Posts: 3


OK, this seems to be a bug. The problem is, the bot doesn't recognize my password:

Code
[01:03:45] <NightE> --> Enter Your Password:
[01:03:59] <Entropy> P831GRKM7
[01:03:59] <NightE> --> Invalid password, bye bye.


The password is correct (How you think could I initiate admin DCC chat without it? =/).

And from php logs:

Code
Notice: Undefined offset: 29 in socket.php on line 920
Trying to get property of non-object in socket.php on line 920


So the $line['cmd'] variable (one that should contain the password) is empty.
> Whoops, seemed to be wrong ^_^

What I've done wrong?

Last edited by Entropy at 8:00 pm, Feb 19 2007

Manick
Post #465
user avatar
Admin
Date: 7:51 am, Feb 19 2007
Posts: 223


what version are you using? we had this bug in older versions.. but i thought it was fixed...

--Manick
PHP-IRC Developer
Entropy
Post #466
user avatar
Member
Date: 1:17 pm, Feb 19 2007
Posts: 3


I am using 2.2.1 (The lastest found in downloads section). Ini.php patch applied, if it does matter.

Manick
Post #467
user avatar
Admin
Date: 6:48 pm, Feb 19 2007
Posts: 223


have you tried with a different password? Try with like "test" or something...

--Manick
PHP-IRC Developer
Entropy
Post #468
user avatar
Member
Date: 7:59 pm, Feb 19 2007
Posts: 3


Aw

Finally figured it out

DCC admin chat doesn't support upper-case letters in password, so 'test' works and 'tesT' doesn't. It is a problem with

Code
$line['cmd'] = irc::myStrToLower($rawLine);


in parser::CreateLine - the string is lowercased at early processing stage. myStrToLower could be removed, but I'm not sure if it breaks something, so it's up to you.

And about these notices - they appear when bot reports that the password is incorrect and closes DCC connection.

Manick
Post #469
user avatar
Admin
Date: 11:15 pm, Feb 19 2007
Posts: 223


yea, notices and myStrToLower have been fixed in 2.2.2 some time ago. Sorry that they are causing your problems.

--Manick
PHP-IRC Developer
   

Back to PHP-IRC Bugs